1. Prva stran
  2. Dokumentacija
  3. EBA Tools
  4. EBA Developer
  5. Obrazci

Obrazci

V EBA Developerju lahko med drugim kreiramo tudi elektronske obrazce.

Elektronske obrazce lahko uporabljamo za kreiranje različnih tipov dokumentov, katere bi sicer kreirali v nekem drugem okolju ali pa bi jih celo izpolnjevali ročno.

Klasičen primer kreiranja obrazcev so recimo interne naročilnice, obrazci za potne naloge, dopust ipd.

Postopek kreiranja obrazca

  • Kreiramo obrazec .form v EBA Developerju
  • Obrazec pripravimo za prenos v EBA DMS z ukazom Deploy – format .exf
  • Obrazec uvozimo v EBA DMS, ga aktiviramo in nastavimo ustrezne pravice. Opomba: Ko popravljamo podatke na obrazcu in želimo objaviti sprembe v EBA DMS, postopek ponovimo le z razliko, da obrazec dodamo kot novo verzijo.

Poženemo EBA Developer, ki se nahaja v bin mapi EBA DMS klienta, privzeta pot je C:\Program Files\EBA\bin\ebadeveloper.exe. Če v mapi ne obstaja ta zadetek, pomeni da nimate nameščenih EBA Tools.

Povezava z EBA DMS podatkovno bazo

Najprej je potrebno EBA Developer povezati z EBA DMS podatkovno bazo, da prenesemo kataloge in tipe dokumentov, za katere bi radi kreirali obrazce.

Povezavo nastavimo v meniju Tools>Options>Database Connections.

Tu nastavimo povezavo enako kot v EBA DMS, ali pa jih preprosto uvozimo iz obstoječe .INI datoteke s klikom na gumb “Import from ini file”.

Kreiranje obrazca v EBA Developerju

Nov obrazec kreiramo tako, da gremo na File>New file or project ali stisnemo hkrati tipki ctrl+n.

Odpre se nam okno, kjer izberemo Form Project in kliknemo gumb V redu.
Program bo od nas zahteval vnos podatkov:

Slika 1: Kreiranje novega obrazca

Name: Vpišemo ime obrazca, brez presledkov (namesto uporabimo podčrtaj) in šumnikov.
Create in: Določimo, kam se obrazec shrani.
Caption: Opcijsko – vpišemo naziv obrazca za prikaz.
Description: Opcijsko – vnesemo opis obrazca.
Icon: Opcijsko – obrazcu lahko definiramo svojo ikono.

Slika 2: Primer novega obrazca

Potrdimo in v naslednjem oknu ponovno, kjer vidimo, v katero datoteko se bo projekt zapisal:

Slika 3: Zaključek

Kliknemo na puščico, da se odpre seznam datotek. Z dvoklikom na *.form datoteko odpremo obrazec (samo ko odpiramo nov projekt, drugače se obrazec odpre samodejno).

Slika 4: Odpiranje obrazca za urejanje

Po dvokliku na .form datoteko, se nam odpre obrazec in orodja, za urejanje:

Slika 5: Orodja za urejanje obrazca

Opis posameznih polj za urejanje:

Seznam datotek v projektu – Seznam datotek, ki so v istem direktoriju kot obrazec. V primeru dodajanja slik na obrazec, se dodane datoteke pojavijo tu.

Objekti Objekti, s katerimi gradimo vsebino obrazca. Objekti so lahko npr. tekst, slika ali pa polje za vnos teksta. Seznam in opis v nadaljevanju dokumenta. Objekte dodajamo po “drag&drop” principu.

Urejanje vsebine in izgleda obrazca – v tem polju urejamo izgled obrazca.

Seznam objektov na obrazcu – Seznam objektov na obrazcu. Predlagamo, da vsak dodan objekt na obrazec smiselno poimenujete (objectName), saj to poenostavi kasnejše urejanje obrazca).

Urejanje objektov – Polje, kjer urejamo posamezne objekte, npr. barvo in velikost pisave, velikost posameznega objekta…


Kako vam lahko pomagamo?